Вопрос: EXCEL: Как записать условие с ячейками на сумму, содержащими конкретный цвет? | Onpioneer

EXCEL: Как записать условие с ячейками на сумму, содержащими конкретный цвет?

У меня есть календарь, если я какое-то число заполняю каким-то конкретным цветом из палитры, то в другой ячейке активируется формула на сумму. Допустим, заполняю пять ячеек цветом, он мне складывает эти пять ячеек, с заранее прописанным конкретным числом (складываю пять дней, заранее задав на конкретный цвет конкретное цифровое значение, например сто, и в ответ в другую ячейку записывается 500). Это возможно?Андрей Силаев
Никак. Можно написать свою функцию, которая вернёт «номер» цвета заливки ячейки, но она не будет пересчитываться при изменении цвета «ручками». Так что это очень плохая идея!

Вот, перечитай…
http://qaru*site/questions/219340/excel-formula-to-get-cell-color

Заменить звёздочку на точку в ссылке.
Полосатый жираф Алик2
Всего 1 ответ.

Другие интересные вопросы и ответы

Как в Microsoft Excel посчитать количество ячеек с определенным значением?

Гость5

Для подсчета количества ячеек с определенным значением надо воспользоваться командой, которую надо разместить в любую свободную ячейку.

=СЧЁТЕСЛИ(A1:С8;»значение»)

A1:С8 — нужный диапазон (у меня написан произвольный),

а в кавычках необходимо указать искомое значение.

Albert Rosenfield6
Всего 1 ответ.[my_custom_ad_shortcode1]

Как копировать отрицательные числа в таблицы excel?

Григорий Родбел1

Задать нужным ячейкам формат «числовой» — и все будет туда нормально копироваться.
Но только проверить, что в источнике точно стоит знак «минус» (ну точнее, обычный дефис там ставится чаще всего), а не длинное или среднее тире какое-нибудь. Их Эксель может трактовать и иначе.

Родион Водейко1
Всего 1 ответ.

Что делать, если хочешь проявить инициативу в общении с противоположным полом, но боишься делать это слишком активно из-за боязни быть навязчивым человеком и из-за сомнений по поводу отношения этого человека к тебе?

Гость6
Если уже есть конкретный объект, на счет которого остро стоит вопрос проявить инициативу или молчать в трубочку.
То тут все просто мой уважаемый анонимчик.
Это есть палка 2-х концов.
Какую выберешь такая и будет вести тебя.
Ты или активно действуешь дабы заявить о себе, своих целях и желаниях. Просто прямо говоришь все, что тебе нужно.
Дабы, (выражаясь попроще) «не трахать» себе самому мозг.
Или молчишь, мучая себя и утопая в надежде, что человек проявит инициативу сам.
Если ты парень и ждешь инициативу от девушки — забудь.
Они и пишут то первыми крайне редко, не говоря уже о том, чтобы четко и прямо описать желаемое.
Если же девушка — как хочешь.
Можешь ждать — благо «рыцарей-мечтателей-альфа» сейчас 1\3 население. Или если он относится к 2\3 оставшимся выложить все карты сама.
Если вопрос к противоположному полу в целом, то тут все сложнее.
Самый простой способ (вернее он чертовски сложный, но усилий минимум) — сайты знакомств.
Там ты подберешь все, что тебе нужно. Но:
— много воды
— много фейков
— имбицилов обоих полов не меньше.
Слишком активно и не нужно.
Смотришь на фото\интересы , формируешь предложение приветствие и за что можно зацепиться и вперед.
Я не Дон Жуан, не Ловелас но опыт в таком тонком деле имею.
Нужны подробности? Милости прошу, отвечу.
Хотя и знаю, что конкретно этот вопрос просто рассылка.
Не, ну а вдруг кого-то заинтересует?
Всего лишь твоя тень1
Всего 1 ответ.

Как в Excel задать сумму ячеек без последней заполненной?

Нужна формула, чтобы в конкретной ячейке отображалась сумма столбца по мере его заполнения, но с условием «минус значение последней заполненной ячейки столбца».

Например, здесь нужно, чтобы в ячейке С24 отображалась сумма (В1:В13), а при добавлении числа в В15 — сумма (В1:В14).

В1

Если у вас всегда заполнены первые ячейки и заполнение идет без разрывов, то попробуйте вот так:

=СУММ(«первая ячейка диапазона»:ДВССЫЛ(ADDRESS(СЧЕТЗ(«весь диапазон»)-1;СТОЛБЕЦ(«любая ячейка из этого же столбца»))))

Для варианта, что на скриншоте:

=СУММ(A1:ДВССЫЛ(ADDRESS(СЧЕТЗ(A1:A24)-1;СТОЛБЕЦ(A1))))

СЧЕТЗ — подсчитывает количество непустых ячеек в диапазоне?

СЧЕТЗ(«весь диапазон»)-1 даст число ячеек на 1 меньше

ADDRESS(x;y) — преобразовывает порядковые номера строк и столбцов x и y в текст адреса ячейки.

СТОЛБЕЦ(A1) — возвращает номер столбца

ДВССЫЛ — преобразовывает текст адреса ячейки в ссылку на нее.

СУММ думаю понятно.

Попробуйте у себя, ибо у меня нет екселя, пробовал на либре офисе с теми же функциями (только по другому пишутся) все работает.

Вот моя формула: =SUM(A1:INDIRECT(ADDRESS(COUNTA(A1:A18)-1;COLUMN(A3))))

Как видите

=СУММ(A1:ДВССЫЛ(ADDRESS(СЧЕТЗ(A1:A24)-1;СТОЛБЕЦ(A1)))) и

=SUM(A1:INDIRECT(ADDRESS(COUNTA(A1:A24)-1;COLUMN(A1))))

ничем не отличаются.

DRVaL2
Всего 5 ответов.

Нужно чтобы ячейка в excel приобретала определенный цвет если в ней число 500 или больше, как это реализовать?

Нужно чтобы ячейка в excel приобретала определенный цвет если в ней число 500 или больше, как это реализовать?Guest5

Условное форматирование. Не знаю, какая версия Excel у тебя, но формула =D4>=500 для условного форматирования ячейки D4 должна везде пройти.

Гость3
Всего 1 ответ.
Вам также может понравиться
Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *